前往顾页
以后地位: 主页 > 收集编程 > Jsp实例教程 >

启动Eclipse报错:An error has occurred.See the log file C:ec

时候:2015-06-07 21:32来源:知行网www.zhixing123.cn 编辑:麦田守望者

启动Eclipse报错:An error has occurred.See the log file C:eclipseconfiguration1284535257255.log处理体例

今天下载了最新的eclipse-SDK-3.7.2-win32.zip,解压到C盘eclipse目次下,双击eclipse.exe后,呈现“An error has occurred.See the log file C:eclipseconfiguration1284535257255.log”提示框,eclipse无法翻开。

1284535257255.log部分内容以下:

!SESSION 2012-02-29 17:07:59.855 ———————————————–
eclipse.buildId=M20120208-0800
java.version=1.4.2_03
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.equinox.p2.reconciler.dropins 4 0 2012-02-29 17:08:00.870
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle “org.eclipse.equinox.p2.reconciler.dropins_1.1.100.v20110815-1419 [84]” could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.p2.extensionlocation; version=”0.0.0″
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1327)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1311)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:389)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1131)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 2 0 2012-02-29 17:08:01.183
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-29 17:08:01.183
!MESSAGE Bundle com.ibm.icu_4.4.2.v20110823 [2] was not resolved.
!SUBENTRY 2 com.ibm.icu 2 0 2012-02-29 17:08:01.183
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.5
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-29 17:08:01.183
!MESSAGE Bundle org.eclipse.ant.launching_1.0.101.v20120110-1739 [16] was not resolved.

经由过程网上查处理体例和多次实验,终究搞定了。处理步调以下:

1、在windows号令行形式下进入eclipse目次下,我这里是:C:eclipse

2、履行eclipse.exe -clean,这时候辰eclipse便可以启动了,并且让挑选workspace目次

------分开线----------------------------
标签(Tag):Java JAVA实例教程 JAVA根本教程 Java源代码 Java技能
------分开线----------------------------
保举内容
猜你感兴趣